Passa al contenuto principale

Creazione di un modello strutturale da un file DWG/DXF con StatiCAD

1. Avviare il programma StatiCAD

2. Accedere al menu DWG Import

3. Utilizzare il comando File>Apri per aprire la finestra di dialogo di apertura file. Cambiare il tipo di file in dwg o dxf. Selezionare il file di disegno e utilizzare il comando Apri per visualizzare il disegno nell'editor di disegno di StatiCAD. Se il file di disegno non riesce ancora ad essere visualizzato nell'editor di disegno dopo questa operazione, provare a salvare il file dwg in formato dwg2007 e ad aprirlo nuovamente nell'editor di disegno di StatiCAD.

  1. StatiCAD utilizza oggetti di tipo linea durante il processo di importazione.

    1. Se si utilizza StatiCAD V6.0.9.0 o una versione successiva, per convertire gli oggetti polilinea del disegno in oggetti linea, selezionare la parte del disegno da importare e fare clic sul comando Converti polilinee selezionate in linee nel menu Modifica. In alternativa, per semplificare l'intero disegno, fare clic sul comando Semplifica disegno per importazione nel menu Modifica. La prima operazione converte le polilinee nella sezione selezionata del disegno in linee. La seconda operazione converte tutte le polilinee del disegno in linee ed elimina gli oggetti rimanenti.
    2. Se si utilizza una versione precedente a StatiCAD V6.0.9.0, prima di aprire il file di disegno in StatiCAD, esplodere (explode) il disegno in AutoCAD per convertire gli oggetti polilinea in oggetti linea.

5. Nell'editor di disegno, fare clic sul pulsante osnap e nella finestra di dialogo che appare, selezionare le opzioni Object Snap On ed Endpoint, quindi premere OK.

  1. Dopo aver selezionato l'intero disegno con una finestra di selezione, fare clic sul comando Sposta sullo schermo (oppure Sposta dal menu Modifica).

7. Fare clic sul punto in alto a sinistra della pianta del piano da importare, premere il tasto Tab sulla tastiera e digitare 0,0 nella riga di comando che appare sullo schermo. Quando si digita zero virgola zero, assicurarsi che il separatore sia una virgola e non un punto. Premere Invio. Il disegno verrà spostato al punto 0,0 tenendo conto del punto base indicato.

(È possibile utilizzare il tasto Tab della tastiera nell'editor di disegno per inserire le quote mentre è attivo qualsiasi comando — linea, cerchio, sposta, copia, ecc.)

8. Fare clic sul comando Vista>Zoom Esteso o sul collegamento a schermo per visualizzare nuovamente l'intero disegno. Premere Esc per deselezionare il disegno.

9. Utilizzare il comando Strumenti>Distanza per misurare la distanza tra due punti di dimensioni note e determinare se il disegno è stato eseguito in cm, mm o m. Se le dimensioni non sono in cm, selezionare il disegno e utilizzare il comando Scala per convertirlo in cm.

10. Per nascondere i livelli (layer) ritenuti superflui nel disegno, selezionare una linea appartenente a quel livello. Fare clic sul pannello Proprietà per individuare il livello dell'oggetto.

11. Utilizzare la finestra di dialogo Formato>Livello per disattivare il livello interessato.

12. In questa fase è possibile eseguire un backup del disegno modificato utilizzando il comando File>Salva con nome in formato dwg o lcd. Se il salvataggio in formato dwg causa problemi, salvare il disegno in formato lcd.

13. Sullo schermo vengono configurate le impostazioni del piano, la selezione del piano (in quale piano effettuare l'importazione) e le impostazioni generali del progetto.

14. Fare clic sul comando Muro nella barra degli strumenti di importazione. L'importazione dei muri uno alla volta è più efficiente; l'importazione multipla di muri potrebbe non funzionare correttamente per ogni progetto.

15. Nella finestra delle proprietà del muro che appare, modificare i valori appropriati e selezionare il materiale. Se si tratta di un piano o di una struttura esistente, impostare il coefficiente di sicurezza a 1.

16. Se i nostri muri sono composti da linee (line, non polyline), possiamo iniziare l'importazione dei muri selezionando due linee alla volta.

17. Man mano che le linee importate vengono convertite in muri, le linee diventano rosse.

18. Dopo il processo di importazione, gli angoli dei muri e le sezioni intermedie potrebbero risultare non collegati.

20. Per questa situazione, selezionare i due elementi da intersecare nella schermata principale e utilizzare il pulsante Interseca 2 elementi nel menu laterale destro per intersecare automaticamente gli elementi.

21. Se gli assi di riferimento non sono stati importati, possono essere creati automaticamente utilizzando l'opzione Crea assi se non esistono nel menu Modifica della schermata principale.

22. Utilizzando il comando Unisci muri, i muri frammentati collegati testa a testa possono essere riuniti in un unico elemento.

23. Selezionando un asse e un elemento, è possibile utilizzare l'opzione Assegna elementi selezionati all'asse selezionato per eseguire l'operazione.

24. Se vi sono elementi errati, è possibile selezionarli facendo clic o con un riquadro di selezione, eliminarli e ricrearli.

25. È possibile importare elementi come porte/finestre, travi, cordoli verticali e fondazioni selezionando due linee alla volta, oppure disegnarli manualmente nella schermata principale.

26. È possibile importare gli assi in blocco selezionando più assi contemporaneamente.