Перейти к основному содержимому

Создание расчётной модели из файла DWG/DXF с помощью StatiCAD

1. Запустите программу StatiCAD

2. Войдите в меню DWG Import

3. Используйте команду File>Open для открытия диалогового окна открытия файла. Измените тип файла на dwg или dxf. Выберите файл чертежа и нажмите команду «Открыть», чтобы отобразить чертёж в редакторе чертежей StatiCAD. Если файл чертежа по-прежнему не отображается в редакторе после этой операции, попробуйте сохранить файл dwg в формате dwg2007 и снова открыть его в редакторе чертежей StatiCAD.

  1. В процессе импорта StatiCAD использует объекты типа «линия» (line).

    1. Если вы используете StatiCAD V6.0.9.0 или более позднюю версию, для преобразования объектов «полилиния» (polyline) в чертеже в объекты «линия», выберите часть чертежа, которую нужно импортировать, и нажмите команду «Преобразовать выбранные полилинии в линии» в меню Modify. Либо для упрощения всего чертежа нажмите команду «Упростить чертёж для импорта» в меню Modify. Первая операция преобразует полилинии в выбранной части чертежа в линии. Вторая операция преобразует все полилинии чертежа в линии и удаляет оставшиеся объекты.
    2. Если вы используете версию, предшествующую StatiCAD V6.0.9.0, перед открытием файла чертежа в StatiCAD выполните команду explode в AutoCAD, чтобы преобразовать объекты «полилиния» в объекты «линия».

5. В редакторе чертежей нажмите кнопку osnap, а в появившемся диалоговом окне выберите параметры Object Snap On и Endpoint, затем нажмите OK.

  1. Выделив весь чертёж с помощью рамки, нажмите команду «Переместить» на экране (или «Переместить» из меню Modify).

7. Нажмите на левую верхнюю точку плана этажа, который нужно импортировать, нажмите клавишу Tab на клавиатуре и введите 0,0 в командной строке, появившейся на экране. При вводе нуля запятой нуля убедитесь, что разделителем является запятая, а не точка. Нажмите Enter. Чертёж будет перемещён в точку 0,0 с учётом отмеченной вами базовой точки.

(Клавишу Tab на клавиатуре можно использовать в редакторе чертежей для ввода размеров при активной любой команде — линия, окружность, перемещение, копирование и т.д.)

8. Нажмите команду View>Zoom Extents или экранный ярлык, чтобы снова отобразить весь чертёж. Нажмите Esc для снятия выделения с чертежа.

9. Используйте команду Tools>Distance для измерения расстояния между двумя точками с известными размерами и определения, в каких единицах выполнен чертёж: см, мм или м. Если размеры не в сантиметрах, выберите чертёж и используйте команду Scale для перевода в сантиметры.

10. Чтобы скрыть ненужные слои в чертеже, выберите линию, принадлежащую этому слою. Нажмите на панель «Свойства», чтобы узнать слой объекта.

11. Используйте диалоговое окно Format>Layer для отключения нужного слоя.

12. На этом этапе можно создать резервную копию отредактированного чертежа с помощью команды File>Save As в формате dwg или lcd. Если сохранение в формате dwg вызывает проблемы, сохраните чертёж в формате lcd.

13. На экране выполняются настройки этажа, выбор этажа (в какой этаж импортировать) и общие настройки проекта.

14. На панели инструментов импорта нажмите команду «Стена». Импорт стен по одной более эффективен; множественный импорт стен может работать некорректно в каждом проекте.

15. В появившемся окне свойств стены измените соответствующие значения и выберите материал. Если это существующий этаж или конструкция, установите коэффициент надёжности равным 1.

16. Если наши стены состоят из линий (line, а не polyline), мы можем начать импорт стен, выбирая по две линии за раз.

17. По мере преобразования импортированных линий в стены линии окрашиваются в красный цвет.

18. После процесса импорта углы стен и промежуточные сечения могут оставаться несоединёнными.

20. Для решения этой проблемы выберите два элемента для пересечения на главном экране и воспользуйтесь кнопкой «Пересечь 2 элемента» в правом меню для автоматического сопряжения элементов.

21. Если оси не были импортированы, их можно создать автоматически с помощью параметра «Создать оси, если они отсутствуют» в меню «Изменить» на главном экране.

22. С помощью команды «Объединить стены» фрагментированные стены, соединённые торец к торцу, можно объединить в единый элемент.

23. Выбрав ось и элемент, можно воспользоваться параметром «Назначить выбранные элементы на выбранную ось» для выполнения операции.

24. Если имеются ошибочные элементы, их можно выбрать щелчком мыши или рамкой, удалить и создать заново.

25. Такие элементы, как двери/окна, балки, вертикальные антисейсмические пояса и фундаменты, также можно импортировать, выбирая по две линии за раз, или нарисовать их вручную на главном экране.

26. Оси можно импортировать массово, выбрав несколько осей одновременно.