使用 StatiCAD 从 DWG/DXF 文件创建结构模型
1. 启动 StatiCAD 程序
2. 进入 DWG 导入菜单
3. 使用"文件>打开"命令打开文件对话框。将文件类型更改为 dwg 或 dxf。选择图纸文件并使用"打开"命令,将图纸显示在 StatiCAD 绘图编辑器中。如果执行此操作后图纸文件仍无法在绘图编辑器中显示,请尝试将 dwg 文件保存为 dwg2007 格式,然后再次在 StatiCAD 绘图编辑器中打开。
-
StatiCAD 在导入过程中使用线对象。
-
- 如果您使用的是 StatiCAD V6.0.9.0 或更高版本,要将图纸中的多段线对象转换为线对象,请选择要导入的图纸部分,然后点击"修改"菜单中的"将所选多段线转换为直线"命令。或者,要简化整个图纸,请点击"修改"菜单下的"为导入简化图纸"命令。第一个操作将所选图纸部分中的多段线转换为直线;第二个操作将图纸中的所有多段线转换为直线,并删除其余对象。
- 如果您使用的是 StatiCAD V6.0.9.0 之前的版本,请在 AutoCAD 中将图纸炸开,先将多段线对象转换为线对象,再在 StatiCAD 中打开图纸文件。
5. 在绘图编辑器中,点击"对象捕捉"按钮,在出现的对话框中选择"启用对象捕捉"和"端点"选项,然后按"确定"。
- 用窗口选择整个图纸后,点击屏幕上的"移动"命令(或从"修改"菜单中选择"移动")。
7. 点击要导入的平面图的左上角点,按键盘上的 Tab 键,在屏幕上出现的命令行中输入 0,0。输入零逗号零时,请确保分隔符为逗号而非句点。按 Enter 键。图纸将根据您标记的基点移动到 0,0 位置。
(在绘图编辑器中,当任何命令处于激活状态时——直线、圆、移动、复制等——均可使用键盘 Tab 键输入尺寸。)
8. 点击"视图>缩放全图"命令或屏幕快捷方式,再次显示整个图纸。按 Esc 键取消选择图纸。
9. 使用"工具>距离"命令测量已知尺寸两点之间的距离,以判断图纸是以 cm、mm 还是 m 为单位创建的。如果尺寸不是以 cm 为单位,请选中图纸并使用"缩放"命令将其转换为 cm。
10. 要隐藏图纸中认为不必要的图层,请选择属于该图层的一条线。点击"属性"面板,查看该对象所在的图层。
11. 使用"格式>图层"对话框关闭相应图层。
12. 此阶段,可使用"文件>另存为"命令将编辑后的图纸以 dwg 或 lcd 格式进行备份。如果保存为 dwg 格式出现问题,请将图纸保存为 lcd 格式。
13. 在屏幕上配置楼层设置、楼层选择(导入到哪个楼层)和项目总体设置。
14. 点击导入工具栏上的"墙体"命令。逐一导入墙体效率更高;批量导入墙体可能并不适用于每个项目。
15. 在出现的墙体属性窗口中,修改相应值并选择材料。如果是已有楼层或既有结构,请将安全系数设为 1。
16. 如果墙体由线段组成(直线,而非多段线),可每次选择两条线开始导入墙体。
17. 导入的线段转换为墙体后,线段变为红色。
18. 导入过程完成后,墙体角点和中间截面可能仍未连接。
20. 针对此情况,在主屏幕上选择要相交的两个构件,然后使用右侧菜单中的"相交两个构件"按钮,可自动完成构件相交操作。
21. 如果未导入轴线,可使用主屏幕"修改"菜单中的"若无轴线则自动创建轴线"选项自动创建。
22. 使用"合并墙体"命令,可将首尾相接的分段墙体合并为一整段。
23. 通过选择一条轴线和一个构件,可使用"将所选构件指定到所选轴线"选项执行该操作。
24. 如果存在错误构件,可点击或用框选选择它们,将其删除后重新创建。
25. 您也可以每次选择两条线来导入门/窗、梁、竖向构造柱和基础等构件,或在主屏幕上手动绘制。
26. 可同时选择多条轴线进行批量导入。