跳到主要内容

示例求解:预制工业建筑

本文以土耳其预制协会(Türkiye Prefabrik Birliği)《按 TBDY-2018 对预制钢筋混凝土工业建筑示例的分析与设计》一书中的示例建筑为例,结合程序自身的屏幕截图,逐步介绍 StatiCAD 的预制(预先制作)钢筋混凝土结构功能:从打开项目、项目设置,到截面与铰接连接、屋面楼板与附加质量、不同的 R-D 设置与分析,再到连接设计和报告。各项功能的详细说明与计算依据,请参阅预制结构的建模、桥式吊车荷载、地震附加质量与不同的 R–D和预制连接设计;与书中结果及 SAP2000 的对比,请参阅预制结构验证研究。

信息

版本: 预制工具(宏菜单中的预制命令、预制截面模板、连接设计窗口、“钢筋混凝土预制”建筑类型、按柱计算位移选项以及报告中的连接页)包含在 StatiCAD Ultimate 版本中。截图取自 StatiCAD Ultimate V.10.0.1.0(64 位,土耳其语界面);根据您的版本不同,部分按钮和文字可能略有差异。

示例文件: 书中建筑的 StatiCAD 模型可向技术支持团队索取。本文使用该文件的副本,名称为 OrnekPrefabrik.sy4,求解结束后保存为 OrnekPrefabrik.sbd;请您也在副本上操作。

1. 示例建筑​

书中的工业建筑是一栋双跨单层预制厂房,其中一部分设有中间层。模型中使用的主要信息如下。

项目数值
平面40 × 75 m;X 方向 11 条轴线,间距 7.5 m;Y 方向 A–E 轴线,间距 10 m;两个 20 m 跨度(A–C 和 C–E)
楼层楼层 1:+5.00(A–C 之间为中间层),楼层 2:+10.00(屋面);每层 500 cm。程序中楼层名称默认显示为“BODRUM KAT”和“ZEMİN KAT”;可在 设置 › 总体楼层设置 中修改。
承重体系与基础固接的柱 60/60(D 轴为 50/50);屋面梁(EÇK)、檐沟和檩条与柱销接;中间层梁为抗弯连接(上部湿接 – 下部焊接);C–E 跨设有 200 kN 桥式吊车
屋面斜屋面梁,因两端为铰接,质量等效地采用棱柱形 40×41 截面;压型钢板屋面,檩条 20/25,并配有 TBDY 附录 8B 等效斜撑(1600 根),形成半刚性楼板
材料混凝土 35 MPa(C35),钢筋 B420C
地震DD-2,SS = 1.153,S1 = 0.318,场地 ZC → SDS = 1.384,SD1 = 0.477;I = 1;上部分区 R = 3,D = 2;下部分区(带中间层的部分)R = 5,D = 2.5(TBDY 4.3.6)
附加质量外墙板的一半质量位于柱顶,桥式吊车的桥架质量位于 C 轴和 E 轴、吊车梁标高(Z = 800 cm)处的两个点上,共 30 个点,均作为“地震附加质量”输入
备注

倾斜(双坡)屋面梁实际上是变截面梁。由于其两端为铰接,侧向分析中不包含抗弯刚度;因此在示例模型中,用质量相同的棱柱形等效截面来表示。变截面(Nonprismatic)和预制模板截面的定义方法见第 6.2 节。

2. 启动程序并打开项目​

  1. 启动 StatiCAD,出现启动界面(图 1)。
  2. 点击左侧栏中的打开按钮(1)。
  3. 在打开窗口中,转到示例文件所在的文件夹(1)。在文件类型列表中选择 StatiCAD Text Data(3)——.sy4 文件属于此类型;.sbd 文件保持默认的 StatiCAD Binary Data 即可。选中文件(2)后点击打开(4)(图 2)。
  4. 项目加载完成后,点击底部停靠栏中的主屏幕图标(图 1 中的 2)。
启动界面

图 1 – 启动界面:1 打开,2 主屏幕

打开窗口

图 2 – 打开窗口:1 文件夹,2 示例文件,3 文件类型(StatiCAD Text Data = .sy4),4 打开

提示

提示: 打开项目时,启动界面上可能出现一个小的三维预览窗口。请等待加载完成(进度窗口关闭)后,再点击主屏幕图标。

3. 主屏幕与熟悉模型​

主屏幕左侧是当前楼层的平面图,右侧是模型的三维视图(图 3)。示例模型中当前激活的是屋面层(楼层 2);平面图上部为带中间层的 A–C 跨,下部为 C–E 跨。由于平面中包含大量檩条和等效斜撑,显得十分密集;如需查看细节,请用 Z.Alan 框选区域进行放大,用 Z.Hepsi 将整个平面图适配到窗口。

主屏幕

图 3 – 主屏幕

编号部分在本示例中的用途
1菜单栏预制工具位于宏菜单末尾(第 5 节)。
2上部工具栏PrjAyar(项目总体设置)、分析、报告、Z.Alan / Z.Hepsi(缩放)、下一层 / 上一层。
3左侧绘图栏选择模式和构件绘制(Seç F,用鼠标选择)。
4平面图当前楼层的平面图;在此选择构件,右键打开其特性。
5三维面板工具栏刷新、楼层和视图按钮。
6三维面板滚动鼠标滚轮进行缩放,拖动旋转。
7右侧工具栏全不选 / 全选(选择)、过滤、特性、3D(独立三维窗口)。
8底部工具栏吸附开关、不足截面、KatSeç。
9当前楼层当前激活楼层的名称。

要查看整栋建筑,请点击右侧工具栏的 3D 按钮打开独立的三维窗口,放大窗口后在其中点击,并用鼠标滚轮缩小视图(图 4)。对于大型模型,可能需要将滚轮转动几十格。

三维视图

图 4 – 示例建筑的三维视图:柱、屋面梁、檐沟、檩条和中间层

4. 项目总体设置​

通过 设置 › 项目总体设置(Ctrl+P)或上部工具栏的 PrjAyar 打开。示例文件中的设置已准备就绪;下面依次列出了预制项目需要检查的选项卡。

4.1 规范选择:建筑类型与延性​

规范选择选项卡

图 5 – 规范选择:1 建筑类型,2 延性等级,3 有限元模型的定义轴线选项

编号字段说明
1建筑类型选择钢筋混凝土预制(Ultimate)。该选项的求解类型与钢筋混凝土建筑相同;此外它会设置钢筋混凝土的默认值,并勾选半刚性楼板的按柱计算位移选项(4.4)。重新打开窗口时,显示的是勾选了钢筋混凝土建筑;设置会被保留。
2延性等级书中示例按高延性等级设计(柱剪力 TBDY 7.3.7,节点剪力 TBDY 7.5)。示例文件以有限保存;如需与书中结果对比,请选择高。
3定义轴线 / 偏移梁相对于柱面的位置(轴线偏移)会传递到有限元模型;保持默认设置。

4.2 TBDY2018:地震参数与 R、D​

TBDY2018 选项卡

图 6 – TBDY2018 选项卡

编号字段示例中的数值与说明
1地震地面运动水平DD-2(设计地震)。
2DD-2 地图谱加速度系数SS = 1.153,S1 = 0.318(取自 AFAD 土耳其地震危险性图)。
3D、I、BKS、R对于带中间层的建筑,此处填入上部分区的系数:D = 2,R = 3;I = 1(BKS = 3)。下部分区的系数在第 10 节的窗口中输入。
4建筑类型(表 4.1)通过请选择...可从 TBDY 表 4.1 中选择体系,并用应用建筑类型数值传入 R、D;预制体系位于 B11–B34 行。示例中数值为手动输入。
5场地土类别ZC;Fs = 1.2,F1 = 1.5 由程序计算。

下方的地震荷载计算中的 5% 附加偏心和在建筑顶部施加附加等效地震荷载选项应保持勾选。

4.3 地震力:模态分析与楼板​

地震力选项卡

图 7 – 地震力选项卡

编号字段说明
1计算方法动力分析与等效地震荷载法对比应用;γE = 0.9(不规则建筑;因书中的 B2 不规则性)。
2采用有限元矩阵的模态分析勾选使用有限元刚度矩阵进行模态分析;振型数为 15。
3模态分析中的刚性楼板指定执行:每层采用三自由度的缩减模型;即使屋面为半刚性,模态分析仍按各层楼板进行。
4不将梁中间节点连接到刚性楼板关闭(默认)。可以开启,以消除因梁轴线偏移而导致静力位移比模态模型偏小的现象(参见预制结构的建模)。

4.4 构件内力:半刚性楼板与按柱计算位移​

构件内力选项卡

图 8 – 构件内力:1 地震工况的楼板选项,2 半刚性楼板中的按柱计算位移

有限元分析中地震工况的刚性楼板选项(1):在带附录 8B 斜撑的屋面条件下工作时,选择半刚性楼板;此时选项卡下方的半刚性楼板中层间位移按柱计算(上–下节点)(2)选项必须开启:相对层间位移按同一根柱的上、下节点位移之差计算,而不是按该层最大与最小节点位移之差计算,这样柔性屋面节点和山墙柱就不会使结果失真。选择钢筋混凝土预制建筑类型时,该选项会自动勾选,并随项目一起保存。

信息

本示例中的选择: 由于书中结果和验证对比均采用刚性楼板求解,因此本文选择了完全刚性楼板(分析时间也更短)。示例文件中的斜撑已建好;如需查看半刚性求解,只需将此选项改为半刚性楼板并重新分析。半刚性屋面的剪切刚度尚未针对书中的楼板性能进行标定;建议同时运行刚性楼板求解,作为设计参考。

4.5 材料​

材料选项卡

图 9 – 材料选项卡:混凝土等级 35 MPa,钢筋 420 MPa

柱/剪力墙、梁、楼板和基础的混凝土等级选择 35 MPa,钢筋等级选择 420 MPa;弹性模量按 TS 500 公式计算(33 227 MPa)。材料名称列仅为标签;计算中使用的是混凝土等级强度和钢筋等级两列。点击 OK 保存设置。

备注

如果窗口无法完整显示在屏幕上(如屏幕缩放比例为 125%),底部的 OK / 取消按钮可能被任务栏遮挡;请从标题栏将窗口向上拖动。

5. 预制工具的位置:宏菜单​

所有预制命令都位于主菜单宏菜单的末尾(图 10,框内):

宏菜单

图 10 – 宏菜单与预制命令

命令功能节
预制屋面楼板等效斜撑(TBDY 附录 8B)附录 8B 计算,并在所选两根梁之间生成等效斜撑7
将所选梁端设为铰接 (M2+M3)销接指定(不弹出窗口)6.3
上部/下部分区采用不同的 R-D (TBDY 4.3.6)...下部分区 R、D 和 ν 的计算10
桥式吊车(行车)荷载...吊车梁设计内力;写入柱上的独立吊车荷载工况(KV、KHX、KHY、KG)和桥架质量9
预制连接设计 (TBDY 第 8 章)...销接、湿接–焊接、檩条/檐沟、外墙板和基础滑移计算13

紧邻上方的 Tum katlarda kesişen seçilen kirişleri böl(在所有楼层中分割相交的所选梁)命令在附录 8B 斜撑之后使用(第 7 节)。斜撑、吊车和连接窗口都不是模态窗口:窗口打开时,您仍可继续在平面图中选择构件。

6. 梁、截面与铰接(销)连接​

6.1 梁特性​

在平面图中选择一根梁,右键点击并运行 修改 <名称> 梁(圈梁)特性 命令。示例中屋面梁(EÇK)在檩条相交处被分割为 2 m 长的段;图 11 中显示的是坐落在 A 轴柱上的端部段 HZ05。

梁特性 - 常规

图 11 – 梁(圈梁)特性,常规选项卡

编号字段说明
1构件类型框架梁(钢筋混凝土)。
2尺寸与附加荷载40/41 等效截面;附加 G 荷载 112.5 kg/m(屋面板和檩条),附加 Q 荷载 562.5 kg/m(雪荷载)。
3截面类型矩形截面或多边形截面;通过选择截面指定预制/变截面(6.2)。
4材料选择默认为项目总体设置 › 材料页中的梁材料(C35 / B420C)。

6.2 预制与变截面定义​

在梁特性中点击选择截面。在弹出的钢截面选择 / 添加(加工制作)窗口中,用户自定义截面...按钮会打开杆件截面特性窗口(图 12)。在模板类型列表(1)中有预制模板(Precast I、Precast U、Precast Box、Precast T、Trapezoidal、Box/Tube)和变截面(Nonprismatic);右侧的列表(2)是已保存的截面和项目中使用的截面。选中模板后点击打开空模板。

杆件截面特性

图 12 – 杆件截面特性:1 模板类型,2 已保存的截面

在 Precast I 模板中(图 13),在截面参数表(2)中以 cm 为单位输入翼缘宽度 B1–B4、高度 D1–D7 和腹板厚度 T1–T2;预览(3)会随尺寸标注即时更新。截面特性选项卡显示面积、惯性矩和剪切面积。通过选择材料将截面材料对应到项目材料(C35);点击保存保存截面,之后即可将其选为梁截面。

Precast I 模板

图 13 – Precast I 模板:1 截面形状类型,2 参数,3 预览

选择 Nonprismatic 后会弹出变截面定义窗口(图 14):截面名称(1)、分段表(2)以及 Add / Delete(3)。对每一段,选择起始和结束截面(取自之前保存的棱柱形截面)、长度(Absolute:cm;Variable:按比例)以及 EI 的变化阶次(Linear、Parabolic、Cubic)。双坡屋面梁由两段定义:端部截面 → 中部截面 → 端部截面。

变截面定义

图 14 – 变截面定义

备注

变截面仅在梁中予以考虑。多边形、预制和变截面钢筋混凝土梁的配筋在分析中自动计算(参见预制结构的建模)。

6.3 铰接(销)连接​

对于屋面梁、檐沟、檩条和吊车梁等销接构件,其端部的 M2 和 M3 弯矩被释放。在梁的铰选项卡(图 15)中,在弯矩 (M2 Minör)和弯矩 (M3 Major)两行中勾选坐落在柱上的端部(1);下方的列表(2)中选择铰适用的荷载工况(全部)。

铰选项卡

图 15 – 梁特性,铰选项卡:HZ05 的柱端 M2 和 M3 释放

对于大量构件,不必逐个设置铰:选中相关的梁(跨所有楼层),运行 宏 › 将所选梁端设为铰接 (M2+M3) 命令。该命令不会弹出窗口;它会在每根所选梁的两端释放 M2 和 M3,将弹簧系数清零,使铰在所有荷载工况下均有效,并在屏幕左下角显示“n kirisin uclari M2+M3 mafsalli yapildi (tum yuklemelerde etkin).”(程序消息:n 根梁的两端已设为 M2+M3 铰接,对所有荷载工况有效)的提示。

提示

提示: 运行命令之前,请检查选择集:之前点击后仍保持选中的构件也会参与处理。要清除选择,请使用右侧工具栏的全不选按钮(Esc 并不总能取消选择);提示中的梁数应与您所选的构件数一致。

危险

对于被分割的屋面梁,仅对坐落在柱上的端部段应用该命令。该命令会使每根所选梁的两端变为铰接;若应用于中间段,梁内部会出现铰,体系将变成机构。错误的操作可用撤销(Ctrl+Z)撤回,或在铰选项卡中删除端部段的内侧端。

7. 屋面楼板:TBDY 附录 8B 等效斜撑​

压型钢板屋面的剪切刚度用两端铰接的等效斜撑来表示。在 宏 › 预制屋面楼板等效斜撑(TBDY 附录 8B) 窗口中(图 16),输入螺钉、钢板和材料信息(1),点击计算(2),即可得到等效轴向刚度 (EA)e、与 TBDY 公式 (8B.1) 的对比以及等效方形截面(3)。未选择构件时,程序按 2.0 m 的檩条间距和 1.875 m 的步长进行初步计算。

附录 8B 窗口

图 16 – 屋面楼板等效斜撑:1 输入,2 计算 / 在所选 2 根梁之间生成斜撑,3 结果

  1. 在平面图中选择斜撑将布置在其间的两根平行梁(相邻的两根屋面梁或檩条)。
  2. 点击在所选 2 根梁之间生成斜撑;两梁之间按所选的分格数分成若干单元格,每个单元格内布置一对 X 形斜撑(构件类型 prefcapraz,两端铰接,无质量)。
  3. 生成的斜撑和源梁保持选中;通过 宏 › Tum katlarda kesişen seçilen kirişleri böl(在所有楼层中分割相交的所选梁),使斜撑端部与檩条和梁在共同节点处连接。

示例模型中的斜撑已建好(1600 根);在三维视图和平面图中呈细斜线。在该模型中请勿再次运行在所选 2 根梁之间生成斜撑,否则同一单元格内会增加第二套斜撑。对于带斜撑的屋面,必须选择半刚性楼板(第 4.4 节)。

8. 外墙板和吊车质量(地震附加质量)​

悬挂在柱上的外墙板仅以地震质量的形式参与承重体系。吊车桥架的质量同样是地震附加质量;这部分质量既可以像本节所述手动输入,也可以通过吊车窗口写入,但只能二选一。吊车车轮荷载和桥架自重则在吊车窗口中作为独立的吊车荷载工况写入(第 9 节)。在质量作用点放置预定义节点,并在预定义节点特性窗口常规选项卡的地震附加质量框中,以吨为单位填入质量(图 17)。

预定义节点特性

图 17 – 预定义节点特性:1 地震附加质量(吨),2 节点坐标

  1. 在平面图中选中施加质量的柱(如檐沟标高处的边柱),打开 宏 › 添加预定义节点... 窗口(图 17a)。勾选在所选立柱/柱的轴线上和立柱/柱上端选项;对于吊车牛腿之类的中间标高,选择在下方的 Z 标高处,并将 Z 填为绝对标高(cm)。在地震附加质量框中以吨(= kNs²/m)为单位输入质量,然后点击 OK。每根被选中的柱的轴线上会创建一个预定义节点并写入质量;节点在平面图中以空心方块符号显示。
  2. 如需之后修改质量,请右键点击节点符号,选择 ... 修改预定义节点特性,在地震附加质量框中输入新数值(1),然后点击 OK(图 17)。
添加预定义节点窗口

图 17a – 宏 › 添加预定义节点:1 位置(所选柱的轴线或坐标),2 标高(柱上端或 Z 标高),3 地震附加质量

备注

节点在分析中连接到坐标相符的有限元节点。柱的上端是一个柱节点;如果节点位于柱的楼层高度范围内、并落在其截面之内的中间标高处(例如吊车牛腿),则柱在该标高处被分段,质量和节点荷载作用于新节点。无法连接到任何节点的点,其质量只计入楼层总质量;分析会在警告列表中报告这一点。

示例模型中有 30 个附加质量点:外墙板的一半质量位于檐沟标高的柱顶(例如 A 轴边柱上为 18.9–23.6 t),桥式吊车桥架重量的一半(166/2 = 83 kN,8.46 t)位于 C 轴和 E 轴、第一个中间轴线(x = 7.5 m)处吊车梁标高(Z = 800 cm)的两个点上。如果在吊车窗口中勾选写入桥架质量的情况下应用吊车荷载工况,这部分质量会被再次写入(参见第 9 节中的警告)。附加质量参与楼层地震质量、模态分析和 θII 指标;由于它不是重量,不会加到竖向荷载和基础上。

9. 桥式吊车(行车)荷载​

在 宏 › 桥式吊车(行车)荷载... 窗口中,输入厂家表中的轮压(R1/R2 最大–最小)、轮距、动力系数、吊车梁跨度、牛腿标高和牛腿偏心距(图 18)。吊车荷载作为独立的预定义荷载工况写入模型;程序在分析中单独求解这些荷载工况,并自行生成吊车组合(参见桥式吊车荷载、地震附加质量与不同的 R–D)。

  1. 计算(1):吊车梁设计内力、传给柱的反力(受载轨道 / 对侧轨道)以及每根柱的水平力列在结果框(5)中。
  2. 选项(2):轨道方向(本例为 X)、对侧轨道的水平力按最小轮压取值(书第 31 页)、桥架自重以 KG 形式参与地震组合,以及吊车组合系数 γK(TS 500,1.6)。在本例中请取消勾选写入桥架质量:桥架质量已在第 8 节中手动输入(图 18 下方的警告)。
  3. 柱(3):在平面图中选中上部分区 C 轴的柱,点击 Ray A ← 所选柱;选中 E 轴的柱,点击 Ray B ← 所选柱;对于桥架自重 (KG) 要分配到的柱,选中第一个中间轴线(x = 7.5 m)上 C 轴和 E 轴的柱,点击 质量 ← 所选柱。
  4. 应用吊车荷载工况(4):在每根轨道柱的轴线上、牛腿标高(Z = 800 cm)处创建一个预定义节点;写入 KV1/KV2、KHX1/KHX2、KHY1/KHY2 荷载工况,勾选 KG 选项时写入 KG 荷载工况,勾选写入桥架质量时写入桥架质量。本例中桥架质量已在模型中,因此应用之前请先阅读图 18 下方的警告。写入的荷载可在节点的预定义节点特性 › 力选项卡中第 13–19 行看到(图 18a)。
吊车窗口

图 18 – 桥式吊车(行车)荷载:1 计算,2 轨道方向和选项,3 轨道柱和质量柱以及写入桥架质量选项(本例中未勾选),4 应用吊车荷载工况,5 结果

示例中的结果:桥架重量 166 kN(质量 16.92 t);KG 荷载工况向两根质量柱各写入 83 kN(如果勾选了写入桥架质量,则每根柱还会写入 8.46 t 的质量);吊车梁 Md = 692.8 kNm,Vd = 516 kN;柱反力在受载轨道上为 305.7 kN,在对侧轨道上为 89.1 kN;每根柱的水平力在桥架方向为 30.6 / 8.9 kN (R/10),在轨道方向为 43.7 / 12.7 kN (R/7)。本例中牛腿偏心距取 40 cm。

吊车节点荷载

图 18a – 预定义节点特性 › 力:C 轴第一个中间轴线柱的牛腿节点(Z = 800 cm);1 吊车荷载工况。该柱在 KV1 中位于受载轨道(FZ = −305.74 kN,MX = −305.74 × 0.40 = −122.3 kNm),在 KV2 中位于对侧轨道(−89.1 kN);KHX1 制动力 R/7 = 43.7 kN,KHY1 桥架方向力 R/10 = 30.6 kN;由于是质量柱,KG = −83 kN(MX = −33.2 kNm)

危险

不要重复计算桥架质量。 示例模型中的桥架质量按第 8 节所述手动输入:在 C 轴和 E 轴、第一个中间轴线(x = 7.5 m)处吊车梁两端的两个预定义节点上,各输入 8.46 t 地震附加质量。而吊车窗口会把桥架质量写入它自己在柱轴线(截面中心)上创建的节点;这些节点不会与手动输入的节点合并。因此,如果在勾选写入桥架质量的情况下应用吊车荷载工况,同样的 16.92 t 会被再加一次;附加质量总和将由 584.4 t 变为 601.3 t。本例中,请在应用吊车荷载工况之前取消勾选写入桥架质量(KG 荷载工况不受该选项影响)。在您自己的项目中,如果要通过吊车窗口写入桥架质量,就不要再另行手动输入质量。吊车窗口会替换其写入质量的节点上的现有数值;重新应用不会使质量累加,移除吊车会恢复该节点原先的数值。

备注

分析时,组合列表末尾会增加十个吊车组合 (1.4G+1.6Q+1.6·KVi ± 1.6·KHXi / KHYi);吊车荷载不进入地震组合,只有 KG(桥架自重)按 G 系数加入。吊车梁和轨道自重的牛腿集中力(计算列表)只有在吊车梁未在模型中定义为梁时,才需另行加入 G 荷载工况。示例模型中的吊车梁是位于 C 轴和 E 轴、顶标高 800 cm、两端铰接的 30/63 梁;它们的自重(连同 40 kg/m 的附加 G 荷载,约 5.1 kN/m,等于窗口中输入的梁 + 轨道荷载)已包含在 G 荷载工况中,因此请勿输入这些集中力,否则会重复计算。本例中未对吊车牛腿进行验算;如果在柱属性窗口的牛腿选项卡中将其定义为短牛腿,其需求将自动取自吊车节点和搁置在牛腿上的梁(参见短牛腿设计)。要从模型中去除吊车,请使用移除吊车。

10. 上部/下部分区采用不同的 R 和 D(TBDY 4.3.6)​

由于带中间层的(下部)分区的承重体系与上部分区不同,需应用 TBDY 4.3.6。在 宏 › 上部/下部分区采用不同的 R-D (TBDY 4.3.6)... 窗口中(图 19):

  1. 勾选对上部/下部分区应用不同的 R 和 D 系数;下部分区最后一层 = 1。
  2. 下部分区 R (X)、R (Y) = 5;下部分区 D (X)、D (Y) = 2.5(下部分区体系在表 4.1 中的数值)。
  3. 如果将 nu_üst 框保持为 0,ν上 将在分析中根据楼层重量和高度(w·H 比值)计算。本例为了与书中结果对比,输入了书中 B 工况的数值:ν上 = 0.320 (X) / 0.261 (Y)(书中的 ν上 取自 R = 1 的模态分析;图 22)。
  4. 点击计算 / 显示进行预览,然后点击确定。
备注

计算 / 显示会将输入的数值同时应用到项目中;之后点击取消并不会撤销这一更改。如需放弃,请重新输入原来的数值。

不同 R-D 窗口(分析前)

图 19 – 不同 R-D 窗口,分析前:1 输入,2 计算 / 显示,3 预览

分析之前,楼层重量尚属未知,因此预览以一行“UYARI”(警告)开头,并显示 ν上 = 1;精确数值在分析后可在同一窗口中查看(第 12.3 节,图 22)。

11. 分析​

分析 › STATIK ANALIZ YAP(Shift+R)或上部工具栏的分析按钮会打开静力分析窗口。点击开始分析(3)启动分析;各阶段和模态分析的周期可在上方列表(1)中跟踪,分析结束后,错误和警告会出现在下方列表(2)中(图 20)。

静力分析窗口

图 20 – 静力分析:1 分析阶段,2 错误/警告列表,3 开始分析

  • 耗时: 在本示例中(1600 根等效斜撑、720 段檩条、完全刚性楼板),分析约耗时 26 分钟(1583 s)。分析进行期间请勿在程序中进行其他操作;结束时列表中会出现“Analiz Tamamlandı”(分析完成)和耗时一行。
  • 警告: “T001 … T006 Temelinin üzerinde duvar bulunamadı”(T001 … T006 基础上未找到墙体)这几行仅供参考:连续基础(地梁)上没有墙体,这在预制建筑中是预期情况。抗震缝一行(M.4.9.3)给出与相邻建筑之间应留的最小间隙(楼层 1:3 cm,楼层 2:5 cm)。
  • 分析结束后会弹出截面不足颜色代码窗口,不足的构件在平面图中以彩色显示。彩色显示可通过底部工具栏的不足截面按钮开启或关闭。
备注

吊车荷载工况: 如果已按第 9 节应用了吊车荷载工况,分析会单独求解这些荷载工况(KV1、KV2、KHX1、KHX2、KHY1、KHY2、KG),并在组合列表末尾添加吊车组合;分析时间会有所延长。本节中的耗时以及第 12–15 节中的结果、报告和图纸截图,均取自未应用吊车荷载工况的求解。应用吊车后,柱、梁、基础和连接设计也会涵盖吊车组合;尤其是 C 轴和 E 轴柱的配筋和基础结果可能与本文所列不同。

备注

在项目总体设置中点击 OK 会使分析结果失效(即使设置没有变化)。在生成报告和图纸之前,请重新运行分析。

12. 结果检查与对比书中结果​

12.1 地震计算汇总​

以下数值取自本文的求解(完全刚性楼板、高延性、开启不同的 R-D、ν上 = 0.320 / 0.261)。书中数值用于对比;详细讨论见预制结构验证研究一文。

参数书中StatiCAD评价
SDS / SD11.384 / 0.4771.384 / 0.477相同
等效法中的 Tp(1.4·TpA 限值)0.787 s0.787 s相同
总地震质量3243 t3232.7 t−0.3%(含附加质量:584.4 t)
楼层力份额(楼层 1 / 楼层 2)0.424 / 0.5760.421 / 0.579量级相同
等效地震荷载 VtE4852 kN(R = 4)6404.7 kN(Ra,上 = 3)书中采用了下部分区取整后的 R;对应 R = 3 时约为 6430 kN
主要周期(模态)Tx 1.107 / Ty 1.042 s0.821 (X) / 0.849 (Y) s;第 1 振型 0.853 s(耦合)差异源于屋面楼板的理想化;同一模型在 SAP2000 中相差在 1% 以内
模态底部剪力 Vt,din(X / Y)–5744 / 6151 kNβ = 1.00 / 1.00(书中 Y 向为 1.09)
二阶效应指标 θII,max0.0490.015 / 0.021限值 0.16;无二阶效应
A1 扭转 / B2 软弱层– / 有(2.59 / 2.27)无 (ηbi ≤ 1.16) / 无刚性屋面的结果
有效相对层间位移 λΔ/h,楼层 1(X / Y)0.011 (Y)0.0078 / 0.0130限值 0.016,满足
有效相对层间位移 λΔ/h,楼层 2(X / Y)0.012 – 0.0130.0104 / 0.0166Y 向超过限值(0.016)
ν、(R̄a)下、D̄下(X / Y)第 4.3 节0.728 / 0.704;4.12 / 4.26;1.93 / 2.02方法相同

12.2 模态分析​

在 表格 › 有限元模态分析 窗口中,从表格列表中选择(如质量参与比),点击显示所选表格(图 21)。前三个振型是含 X、Y 和扭转分量的耦合振型;到第六个振型时,两个方向的质量参与均达到 100%。

模态分析结果

图 21 – 模态分析结果:质量参与比

12.3 不同 R-D 的结果​

分析之后,在 宏 › 上部/下部分区采用不同的 R-D 窗口中点击计算 / 显示,即可给出精确数值(图 22,1):ν = 0.728 / 0.704,(R̄a)下 = 4.121 / 4.259,D̄下 = 1.929 / 2.018。下部分区(楼层 1)构件的地震内力按 ν 放大,抗剪承载力计算采用 D̄下。

不同 R-D,分析后

图 22 – 不同 R-D 窗口,分析后:1 ν、R̄a 和 D̄ 数值

12.4 柱配筋​

表格 › 柱表列出每根柱所需和所选的纵向钢筋、箍筋以及设计组合(图 23)。程序从 表格 › 配筋选择 窗口柱选项卡中已开启的直径里选择纵向钢筋:柱中不使用细于 Ø14 的钢筋(TBDY 7.3.2.1),且同一面上钢筋之间的净距不得小于 max(1.5Ø; 40 mm)(TS 500 9.5.2);在满足这些条件的布置中,选择面积最小者。示例中,楼层 1 的大多数 60/60 柱所需配筋为 95–114 cm²;程序选用了 Ø20 的 34–40 根钢筋(107–126 cm²,3.0–3.5%)。

柱表

图 23 – 柱配筋表

危险

需要工程判断的结果:

  • 楼层 2,Y 向相对位移 0.0166 > 0.016: 报告中会出现“Etkin göreli kat ötelemeleri sınırı aşılmaktadır”(有效相对层间位移超过限值)的消息。书中同一楼层的结果为 0.012–0.013;差异来自屋面楼板和框架的理想化(参见验证研究)。需要增大柱截面,或与半刚性屋面的求解结果进行对比。
  • 纵向钢筋净距(TS 500 9.5.2): 示例文件中柱的直径列表为 Ø12–Ø20。60/60 截面用 Ø20 最多只能布置约 88 cm² 的钢筋;对于需要更多钢筋的柱,已开启的直径中没有一种能放得下,程序使用最大的已开启直径,并给出“TS500 9.5.2 … Donati kesite sigmiyor”(钢筋无法放入截面)的错误消息(图 35;示例中楼层 1 有 33 根柱,楼层 2 有 24 根柱)。解决办法:在 表格 › 配筋选择 窗口的柱选项卡中,于 Minör 和 Majör 行勾选 Ø22–Ø32,点击 OK 关闭后重新分析(图 23a),或增大柱截面。在本例中,开启大直径后所有净距消息均消失;程序在 60/60 柱中选择 28Ø22(106.4 cm²)、24Ø24(108.6 cm²)、18Ø28(110.8 cm²)等布置。地震计算和相对位移不变。
  • 搭接接头: 在配筋率超过 3% 的柱中,如果所有钢筋在同一截面搭接,配筋率会超过 6%(TBDY 7.3.2.2 错误消息;示例中楼层 1 有 18 根柱,楼层 2 有 13 根柱)。请错开接头位置、使用套筒接头,或增大柱截面。
  • DHZ34 和 DHZ35: 所需配筋达到毛截面的 4%(TBDY 7.3.2.1 错误消息)。若 Ø32 已开启,则锚固入屋面梁所需的弯折段长度还会超过梁高(TBDY 7.3.3.2)。这两根柱的截面必须增大。
配筋选择,柱选项卡

图 23a – 配筋选择窗口,柱选项卡:1 柱纵向钢筋行(示例中已开启 Ø12–Ø20),2 为满足净距可开启的大直径(Ø22–Ø32)

错误检查菜单中的执行抗震规范错误检查列出的是砌体建筑特有的墙体检查;对于预制建筑,柱和位移的检查请通过报告中的相应页面进行。

12.5 对比结果的解读​

  1. 周期: 书中的 SAP2000 模型中屋面为半刚性,唯一的主导振型表现出柔得多的框架行为。StatiCAD 的有限元模型在相同模型下与 SAP2000 的吻合在 1% 以内;β、θ 和 B2 比书中数值偏小,也源于这一差异。
  2. R = 3 和 R = 4: 书中采用下部分区取整后的系数计算等效荷载;StatiCAD 直接应用 TBDY 4.3.6。换算后,楼层力分布是相同的。
  3. 程序中尚无的内容: 连梁力 Nb(TBDY 16.8.5)和杯口基础验算在本版本中尚未提供。

13. 连接设计(TBDY 第 8 章)​

宏 › 预制连接设计 (TBDY 第 8 章)... 窗口中有五个选项卡:销铰接 (MFB)、上部湿接 – 下部焊接 (MAB3)、檩条 / 檐沟连接、外墙板(第 6 章)和基础滑移 (16.8.4)。输入框默认填入书中示例的数值;您可以写入自己的数值,也可以从分析中提取。每次计算都会生成一条将进入报告连接页的记录。

13.1 销铰接连接 (MFB):从分析中提取需求​

  1. 选择需要设计连接的梁。由于平面中构件很多,最可靠的方法是使用 编辑 › 查找对象(Ctrl+F)窗口:输入构件名称(如 HZ05),必要时勾选在所有楼层中查找,然后点击查找并选择。
  2. 在 MFB 选项卡中,将端部选择器切换到坐落在柱上的一端(HZ05 为右端),并点击从所选梁提取(分析结果)(1):连接质量、梁自重、支座竖向荷载和梁轴向力会被填入;详细信息写在下方的文本区域(2)中。
  3. 点击计算 MFB。
MFB,从分析中提取的需求

图 24 – MFB 选项卡:1 从所选梁提取 + 端部选择,2 从分析中提取的需求及计算结果

对于 HZ05(右端):mk = 8.92 t,W1 = 175.0 kN,N = 92.6 kN,N梁 = 0.4 kN。倾覆拉力 T = 199.0 kN → 插筋 As = 545 mm²(2Ø36 = 2036 mm² 足够);销钉剪力 Ve = 0.8 kN ≤ Vr = 173.3 kN;d/φ = 6.5 > 6 → SAĞLANIYOR(满足)。

备注

为什么 N梁 ≈ 0? 在完全刚性屋面楼板的情况下,铰接屋面梁的地震轴向力接近于零(屋面质量的惯性力由楼板承担)。对于销钉剪力,有意义的 N梁 应取自半刚性(带附录 8B 斜撑)模型或手算后输入。按书中数值 N梁 = 80 kN 计算:Ve = 160 kN ≤ Vr = 173.3 kN(比值 0.92)。

13.2 上部湿接 – 下部焊接连接 (MAB3)​

选择中间层梁 HB03,并对左端(B 轴)从分析中提取,得到 Md− = 1525.5 kNm。程序计算上部连续配筋(5104 mm²)、焊接下部钢筋和钢板、水平剪切插筋以及 2h 区的箍筋。若将已提供框保持为 0,则采用所需数值;这里输入下部钢筋 2600 mm² 和箍筋肢数 3,所有验算均得到满足(图 25)。

MAB3 结果

图 25 – MAB3 选项卡:从分析中提取的弯矩包络和设计结果

13.3 檩条/檐沟、外墙板和基础滑移​

在这些选项卡中,使用书中数值执行了计算(图 26–28)。对于檩条/檐沟,验算销钉剪切–摩擦、角焊缝和檩条屈曲;对于外墙板,验算 TBDY 第 6 章等效地震荷载(Fie = 102.4 kN,下限 41.1 kN);对于基础滑移,验算 Vth = 103 kN ≤ Rth = 107.5 kN。

檩条 / 檐沟
图 26 – 檩条 / 檐沟连接
外墙板
图 27 – 外墙板(第 6 章)
基础滑移
图 28 – 基础滑移 (16.8.4)
备注

窗口的输入值不会随项目保存;只保存计算记录。若以相同类型和构件名称重新计算,则更新该记录。

14. 报告​

  1. 保存项目(第 16 节):报告是根据已保存的文件信息编制的。
  2. 点击上部工具栏的报告按钮(Alt+R),打开报告选择窗口。勾选要纳入报告的部分;展开基础计算节点时,会看到子页预制连接设计 (TBDY 第 8 章)(1)。如果项目中有连接记录,该页会自动勾选。
  3. 点击生成所有选定报告(2)。报告编制完成后会弹出 Preview 窗口(图 30)。
  4. 在预览中,通过工具栏的 PDF 或保存图标将报告导出为 PDF/Word;点击 Close 关闭。
报告选择

图 29 – 报告选择:1 预制连接设计页,2 生成所有选定报告

报告预览

图 30 – 报告预览(Preview):底层柱细长比页

本例中选择了封面、作用于各层的地震荷载、动力分析结果、结构不规则性、基础计算和柱配筋等部分,生成了 171 页的报告。下面给出报告中的示例页面。

地震计算
图 31 – 按 TBDY 2018 等效地震荷载法进行的地震计算
动力分析
图 32 – 动力分析计算报告:模态数值
预制连接设计页

图 33 – 预制连接设计(TBDY 2018 第 8 章)页:每条记录的类型、构件(端部)、需求、承载力、比值和结果

相对位移

图 34 – 有效相对层间位移的计算与限制

柱纵向钢筋
图 35 – 柱纵向钢筋计算:PMM 相互作用图、所选布置以及 TS 500 9.5.2 / TBDY 7.3.2.2 错误消息
柱细长比
图 36 – 柱细长比效应(TS 500 7.6.2;在 α 计算中,销接梁按自由端处理)
备注

不同 R-D 的中间值、吊车、附录 8B 和附加质量没有单独的报告章节;这些数值请从相应窗口中读取。

15. 图纸​

上部工具栏的绘图按钮(Alt+C)会打开绘图选择窗口。在钢筋混凝土绘图选项卡中,选择图纸类型(1)和要绘制的楼层(2),然后点击绘制项目(含展开图)(3)。绘图前必须已完成分析。图纸在 StatiCAD-TechnicDraw(窗口标题为 StatiCAD-CivilDraw)编辑器中打开(图 38);可在其中保存为 DWG/DXF 并打印。本例中绘图耗时约 10 分钟。

绘图选择

图 37 – 绘图选择:1 图纸类型,2 楼层,3 绘制项目(含展开图)

TechnicDraw

图 38 – StatiCAD-TechnicDraw 绘图编辑器:柱定位平面图和梁展开图

下面的图像取自从编辑器中保存为 DXF 的图纸。

屋面模板平面图

图 39 – 屋面(楼层 2)模板平面图:屋面梁、檐沟、檩条和 TBDY 附录 8B 等效斜撑

中间层模板平面图

图 40 – 中间层(楼层 1)模板平面图和中间层梁展开图

中间层梁展开图

图 41 – 中间层梁展开图:纵向钢筋、弯起筋和箍筋布置、横截面

柱竖向展开图
图 42 – 柱竖向展开图:约束区、中间区和搭接区箍筋
基础定位平面图
图 43 – 基础定位平面图(条形基础和柱位)
屋面梁展开图

图 44 – 屋面层梁展开图

备注

图纸中的“Malzeme”(材料)文字取自项目总体设置 › 材料选项卡中的材料名称列;而计算中使用的混凝土和钢筋等级是其旁边的混凝土等级强度和钢筋等级两列。请检查两者是否一致(图 9)。

备注

在多边形和预制截面梁的展开图中,绘制的是实际截面轮廓和钢筋点,而不是矩形;变截面的各站截面以及斜上边缘的展开图不予绘制。

16. 保存​

在生成报告和关闭程序之前,请先保存项目:文件 › 另存为(Ctrl+Alt+S)。在文件名框中输入完整路径(例如 C:\Projeler\OrnekPrefabrik.sbd),然后点击保存。程序会在 .sbd 文件旁同时写入一份 .sy4 文本副本。请确认标题栏显示了新路径,提示行显示了“Data Kaydedildi”(数据已保存)字样。

另存为

图 45 – 另存为窗口(StatiCAD Binary Data,.sbd)

保存的预制数据说明
铰、地震附加质量、变截面定义、预制模板参数在项目结构中
不同的 R-D 设置文件版本 9281 及以后
连接计算记录、按柱计算位移及其他楼板选项文件版本 10003 及以后
吊车定义(窗口输入值、轨道柱和质量柱、写入桥架质量的节点在应用吊车前的质量)和吊车荷载工况文件版本 10017 及以后
备注

示例文件是用旧版本(9281)保存的;打开时,新选项以默认值(关闭)出现。在您自己的保存文件中,这些选项会被保留。连接和附录 8B 窗口中的输入值不会被保存;只保存连接计算记录。

17. 检查清单、限制与常见情况​

17.1 检查清单​

  1. 项目总体设置:建筑类型(钢筋混凝土预制或钢筋混凝土建筑)、延性等级、DD-2 SS/S1、场地类别、上部分区的 R 和 D 系数、γE、材料。
  2. 截面:预制/变截面已保存并指定给梁;如使用等效截面,已保证质量等效。
  3. 销接连接:屋面梁、檐沟、檩条和吊车梁端部的 M2+M3 已释放;中间段无铰。
  4. 屋面楼板:已生成附录 8B 斜撑,并通过 Tum katlarda kesişen seçilen kirişleri böl(在所有楼层中分割相交的所选梁)连接到节点;在半刚性求解中,已选择半刚性楼板和按柱计算位移;作为设计参考,同时完成了刚性楼板求解。
  5. 附加质量:外墙板质量已作为地震附加质量输入;吊车桥架质量通过手动输入或通过吊车窗口的写入桥架质量选项输入,且只输入了一次。
  6. 吊车荷载:已在项目总体设置中选中使用钢筋混凝土-砌体荷载组合;已指定轨道柱和质量柱,并点击了应用吊车荷载工况;如果吊车梁在模型中没有定义为梁,已将吊车梁 + 轨道自重的牛腿集中力输入到 G 荷载工况中。
  7. 不同的 R-D:已输入下部分区最后一层、R 和 D;分析后已检查 ν 和 D̄ 数值。
  8. 分析:已查看警告列表;已检查模态质量参与、底部剪力和相对位移。
  9. 柱配筋:已检查表格 › 柱表和报告中的错误消息;如有 TS 500 9.5.2 净距消息,已扩大配筋选择 › 柱的直径列表或增大截面。
  10. 连接:对每种连接类型都执行了从所选梁提取 + 计算;已生成记录列表。
  11. 项目已保存;报告连同预制连接设计页一并生成。

17.2 本版本的限制​

危险
  • 吊车荷载: 按单一吊车位置建模(所有轨道柱同时受载);没有位置扫描,也不支持多台吊车。吊车荷载工况不参与梁挠度验算和楼板壳单元内力(第 9 节)。吊车荷载只能通过预定义的荷载工况和组合求解:如果在项目总体设置中选中了使用木结构荷载组合,则不会进入分析;使用危险建筑 (RBTE) 荷载组合时不生成吊车组合。这两种情况都会在分析警告列表中提示。
  • 报告: 不同 R-D 的中间值(ν、R̄a、D̄)、吊车、附录 8B 和附加质量没有单独的报告章节;数值请从相应窗口中读取。
  • 变截面仅在梁中予以考虑;截面表中的列标题为英文。
  • 半刚性屋面: 带附录 8B 斜撑的屋面的剪切刚度尚未针对书中的楼板性能进行标定;建议同时运行刚性楼板求解,作为设计参考(参见验证研究)。
  • 短牛腿和吊车牛腿在柱属性窗口的牛腿选项卡中定义,需求取自分析(参见短牛腿设计);本版本中尚无杯口基础和安装阶段的验算。
  • 预制窗口(附录 8B、不同的 R-D、连接)仅提供土耳其语;结果文本中不使用土耳其语特有字符。桥式吊车(行车)窗口跟随程序语言(土耳其语/英语)。

17.3 常见情况​

情况原因 / 解决办法
宏菜单中没有预制命令。预制工具仅在 Ultimate 版本中开放。
点击主屏幕图标后弹出三维窗口,或没有任何反应。点击时项目仍在加载;加载完成后请再次点击图标中央。
项目总体设置的 OK 按钮看不到。窗口无法完整显示在屏幕上;请从标题栏向上拖动。
分析前,不同 R-D 预览中 ν上 = 1。楼层重量在分析中计算;请在分析后读取数值,或手动输入 ν上。
“从所选梁提取”未填充输入框。尚未进行分析,或平面图中没有恰好只选中一根梁。
MFB 中销钉剪力需求为零。在刚性屋面楼板中,铰接屋面梁的地震轴向力为零;请从半刚性(附录 8B)模型或手算中输入 N梁。
柱出现“TS500 9.5.2 … Donati kesite sigmiyor”错误。在已开启的直径下,所需钢筋无法按净距放入截面;请在 表格 › 配筋选择 › 柱选项卡中开启大直径并重新分析,或增大截面(第 12.4 节)。
报告中没有连接页。没有连接记录、报告选择中未勾选该页,或项目未保存。
坐落在柱上的节点无法通过右键选中。如果附加质量点与柱重合,右键点击会捕获到柱;请将节点定义在不与柱重合的位置,或将其作为楼层附加质量输入。而吊车窗口创建的节点必须保留在柱轴线上;请勿移动它们,如需修改吊车荷载和质量,请在吊车窗口中修改后通过应用吊车荷载工况重新写入。
分析警告列表中出现“Projede gezer vinç (kren) yüklemeleri tanımlı ancak analize katılmadı”(项目中已定义桥式吊车(行车)荷载工况,但未参与分析)一行,或吊车窗口中应用吊车荷载工况为灰色(不可用)。吊车荷载只能通过预定义的荷载工况和组合(在项目总体设置中选中使用钢筋混凝土-砌体荷载组合)并在 Ultimate 版本中求解。如果选中了使用木结构荷载组合,请改选使用钢筋混凝土-砌体荷载组合并重新分析;如果之前尚未应用吊车,请先在吊车窗口中应用。
总地震质量比预期的大(本例中附加质量总和为 601.3 t,而不是 584.4 t)。桥架质量既手动(地震附加质量)又通过吊车窗口写入了。请在吊车窗口中取消勾选写入桥架质量并再次点击应用吊车荷载工况,或删除手动输入的质量(第 9 节)。

17.4 相关文章​